Could not load file or assembly FluentSP

Sep 23, 2011 at 12:53 PM

 

Hi,

I created a SharePoint project, and I try to deploy this app which uses the FluentPS libraries. I got this error page:

Could not load file or assembly 'FluentSP, Version=1.4.0.0, Culture=neutral, PublicKeyToken=8cfad612994dc19b' or one of its dependencies. The system cannot find the file specified.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.IO.FileNotFoundException: Could not load file or assembly 'FluentSP, Version=1.4.0.0, Culture=neutral, PublicKeyToken=8cfad612994dc19b' or one of its dependencies. The system cannot find the file specified.

I tried to install FluentPS dll-s to GAC with manually, too. The same result. I'm developing with VS 2010.

Please help me. Thanks a lot.

Csaba

 

Sep 30, 2011 at 7:11 AM
Edited Sep 30, 2011 at 7:11 AM

Hi,

I'm guessing your project references the FluentSP dll. Try referencing that dll explicitly or copy it to the output\bin folder.

 

Christian

Sep 30, 2011 at 12:28 PM

Hi,

Now the problem is solved. The solution was: I needed to upload the FluentPS*.dll-s and FluentSP.dll to the GAC by gacutil.exe, not enough to copy to there. To copy to the bin folder was unsuccessfull.

Thanks,

Csaba

 

cihlen wrote:

Hi,

I'm guessing your project references the FluentSP dll. Try referencing that dll explicitly or copy it to the output\bin folder.

 

Christian